Windows Vista / 7 color fix (by mudlord)

Mar 13, 2010
3,368
2
0
33
Bor, Serbia
#1
Originally posted by mudlord on SevenForums.



Info: Fixes problems with colors on Windows Vista / Windows 7 permanently, without a need to kill "explorer.exe" anymore, nor try any other solutions.

DOWNLOAD :arrow: w7ddpatcher-withsource.zip (source code included)


How to use:


  • 1) Unpack the packed file.
    2) Start w7ddpatcher.exe.
    3) Click Patch, select your game executable (usually C:\Program Files\Microsoft Games\Age of Empires II\age2_x1\age2_x1.exe) and click Open.
Game will start, and as soon as all needed game info is gathered by the program, both game and program will close. That`s all, next time you start the game you won`t have any more color problems.


Additional info:

How does it actually work?

  • 1) App gets HWND/process IDs of application being run.
    2) App runs the application.
    3) It kills its threads as soon as a HWND and thread ID is gathered.
    4) From there, the most recent DirectDraw application ID is gathered. Since it was the app to be patched, it copies it to a variable.
    5) This variable, along with the needed flags makes a compatibility profile in the Registry for Windows Vista/7 to use with that application, only. It won't affect other parts of your registry. The key name used comes from the application's window class name/IDs.
Of course the source explains the details.

.
 

Attachments

UnknownFossE

New Member
Mar 13, 2010
292
0
0
27
#6
wont work for me, after the game is started nothing happens :S how long is it suppose to take before it closes itself?
 
Jan 16, 2010
24
0
1
#14
hi, when i installed it all my patches gone, i mean desert,snow and bamboo, i tried to reinstall but , it doesnt install, any suggestions?
 
Mar 13, 2010
3,368
2
0
33
Bor, Serbia
#15
This doesn`t have anything to do with game files, it just fixes registry to enable better DirectDraw support on Vista / Win7, fixing the color problem.
You tried reinstalling the game, or "patches"?
 

UnknownnC_eru_

New Member
Apr 11, 2010
205
2
0
26
#19
I always got the error "Can't load process!", so I made all steps manually.
If anyone else have that problem, just use this registry script. It should work on any win vista/7 x64 OS, propably also on x86, but I'm not sure. Just test it, it can't destroy anything. :wink:
 

UnknowneGo

New Member
Jun 3, 2008
4
0
0
#21
i have the problem that my hotkey settings are always of whenn i play via vobbly.
can this be becaus of the windows 7 patch?

i installt aoe+c new.
patched it to 1.0c
installt wind7 patch
if i start aoe the hotkey settings are there but wenn ni start voobly there away?
 
Dec 5, 2010
2
0
0
#23

UnknowneGo

New Member
Jun 3, 2008
4
0
0
#24
thank u buzz fosse! this indeet solve my problem.
so for everyone:
patch works with windof 7 64 bit.
hotkeyproblem can be solved by starting exe via admin mode.

thx and happy playing
 

Time

Your time
G M T
Your zone

Upcoming Events

Hidden Cup 2 Qualification
Wednesday 15:00 (GMT +01:00)
F1Re vs Lyx
DeZu's showmatch $100 TheYo vs Lyx, full 7 games
Saturday 14:00 (GMT +01:00)
TheYo vs Lyx showmatch
Bluewolf Showmatch ($10) Episode 2
Saturday 14:30 (GMT +01:00)
TheHappyBoar vs PaperHades
ECL South East Asia 3v3 Ro8
Saturday 15:00 (GMT +01:00)
ECL South East Asia 3v3 Ro8
ECL South East Asia 3v3 Semi Finals & Grand Final
March 30th 15:00 (GMT +01:00)
ECL South East Asia 3v3 Semi Finals & Grand Final

Age Of Empires On Twitch

There are in total 15 streamers online
Click here for details
Age of Empires II 21 viewers
Age of Empires II 9 viewers
Age of Empires II 5 viewers
Age of Empires II 3 viewers
Age of Empires II 2 viewers
Top